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Chapter 1
Getting Started

What is BrightAuthor?
BrightAuthor is a software application that helps you create presentations for your digital sign or
kiosk. You can play your BrightAuthor presentations on BrightSign models: HD110, HD210,
HD410, HD810, and HD1010. Your presentations can include any of the following types of
contents:
* Images
* Videos
* Audio
* RSS
* Text
» Dateortime



What kind of presentations can | create?

The current version of BrightAuthor enables you to create non-interactive presentations that
play the content in a continuos loop. Future versions of BrightAuthor will also support creating
interactive presentations. You can create two types of presentations with BrightAuthor:

* Full screen presentation: Slide shows or videos that occupy the full screen.

* Multi-zone presentation: A presentation with different types of content in each region of the
screen. The screen can include one video zone, and multiple Clock, Text, Ticker, or Image
zones. You can choose one of the predefined layout templates or create your own custom
layout template.

Step 1: Get the hardware you need

To create presentations with BrightAuthor, you need a PC with one of these operating systems:

¢ Windows XP
¢ Windows Vista

To play presentations you create with BrightAuthor, you need the following hardware:
BrightSign Any of the following models:

* HD110

* HD210

* HD410

» HD810

* HD1010

Display Any monitor, TV, or Elo touch screen with one of the following types of inputs:
* VGA

* Component (HD810 and HD1010 only)

* HDMI

Storage card Either of the following:

» USB Flash card (HD810 and HD1010 only)
* SD card

* SDHC card



Card Reader/Writer (not required with USB Flash card) The card reader/writer must be
connected to your PC and must be compatible with your storage card.

Step 2: Install the BrightAuthor software

Download the latest software and install it on your PC.

NOTE: BrightAuthor requires the latest version of Microsoft .Net Framework. If this component is
not already on your PC, BrightAuthor installs it during the installation. However, if BrightAuthor
needs to install Microsoft .Net Framework, the installation may take up to 45 minutes to complete
and you may need to restart your PC to complete the installation process.

1 Go to the BrightSign web site www.brightsign.biz/support.
2 C(lick the BrightAuthor Downloads link.
3 Follow the onscreen instruction to install the software on your PC.

Step 3: Add your content

Your BrightAuthor presentations can include the following types of media files:

* Videofiles. You can use a single file as a loop, or multiplefiles. Video files can be MPEG-2 files
that are saved as transport or program streams, MPEG-1 files that are saved as system streams,
or H.264 files that are saved as transport streams.

* Audio files. Any MP3 audio (in a video or mp3 file) must have a sample rate of 48 kHz,
44.1 kHz, or 32 kHz.

* Imagefiles. For stillimages, use BMP, PNG, and JPEG files. The maximum supported resolution
is 1920x1080.

Step 4: Create your presentations

Now you're ready to start using your BrightAuthor to create presentations. Just add your content
and follow the directions in the rest of this guide to create your presentations.


http://www.brightsign.biz/support

Chapter 2
Creating Presentations

Creating a full-screen presentation

In a full-screen presentation, your images or video occupy the entire screen.

1 Create a new project file:

a Double-click the BrightAuthor icon on your
desktop.

b Click Create a new project.

Create a new BrightSign project

. Save As:  Project 2

c Inthe Save As field, enter a name for the
presentation.

Where:  C\User\Documentsiwaork_projects

BrightSign Model: l HD1010

d Inthe Where field, enter the folder where you want

to store the presentation. To navigate to the folder

Connector type: I HDMI

you want to select, click Browse.

Screen resolution: l 1920x1080x60i

e Select your BrightSign Model, Connector type,
and Screen resolution.

f Click Create.

Create H Cancel |




2 Click the Full Screen template, and then click
Choose.

3 Add your Media Library:
a On the left side of the screen, click Browse.

b Navigate to the folder where your content is
stored.

c¢ Click OK.

NOTE: If you have a lot of large files in your content
folder, it may take a while for the thumbnail images
to appear.

4 Add files to your presentation by dragging files
from the thumbnail list on the left side of the
screen to the playlist bar at the top of the main
screen area.

* To select a series of adjacent files, press
Shift+Click as you select the files.

Select a Template View: | System Templates -

Full Screen

3-zone

5-zone with clock

[7] Images

Choose Cancel |

] Ticker ] Clod

"

[ Video or Images

* To select a group of non-adjacent files, press Ctrl+Click as you select the files.
* To arrange the files in the order in which you want them to play, drag the thumbnails in the

playlist bar.

* To remove an item from a playlist, highlight it in the playlist bar and press Delete on your

PC keyboard.



R Project 1 - BrightAuthor [E=RI X))
File = Edit ~ Help ~ Layout p,r"y““, Schedule &% Publish
1 Videa o Images |E\ Playlists for Zone 1 m
A [+] Playlist 0 EDT X
(7] videoOrmages
.
Media Library = @ videol.mpg imagsljpg imagsjeg
m (4 Add New Playist
CA\Users\Owner\Documents\work_projects E
B ] ~ -~
5 (Optional) Rename the playlist: T ——
a Click Edit in the upper-right corner of the D it iyl =)
playllst bar. Playlist Name:  Attract Loop
b Enter a new name for the playlist. : o Il [F
'.!.
¢ Click OK.
6 (Optional) Set playback options: (o T—— [

* To edit settings for a single item, right-click the thumbnail
in the playlist bar and select Edit, and then choose the
settings you want to apply to the selected item.

Time on screen: 3

Transition: [Fa.d.e to new image ']

G




* To edit settings for multiple items, press Ctrl+Click to select the items in the playlist bar. On
the menu bar, click Edit > Selected Items, and then choose the settings you want to apply to
all of the selected items.

7 Onthemenu bar, click File > Save to store your presentation as indicated when you created
the project.

NOTE: To save the presentation with a different name or in a different folder, select Save As
instead of Save.

8 Publish the presentation on your SD card:
a Insertan SD card into your card reader.
b Click Publish in the upper-right corner.
¢ Select the drive where your SD card is located.
d When the Publish complete message appears, click OK

Browse For Folder &J

Select the presentation target folder

B Patty -
- L. Public R Publish |
4 M Computer

- &, Local Disk (C3)

m

3 Data (D:)
= -
= LEXAR (2GB) (E) Publish complete
- % DVD RW Drive (F:) Mov 24 2008 d2 = =
- 188 My Sharing Folders
- F Network OK Cancel |

. [E Contral Panel

I Make MNew Folder I [ oK ] I Cancel




Creating a multi-zone presentation

In a multi-zone presentation, BrightAuthor divides the screen into rectangles called zones. You
can play different content in each zone and each zone supports a specific type of content.
BrightAuthor includes a handful of multi-zone templates. You can choose one of the existing
templates, or create your own (see Customizing template layouts).

When using a multi-zone template, you need to know which type of content you can include in

each zone. The color-coded key at the bottom of the template screen shows the available

content types, and the color-coded templates indicate which type of content you can include in

each zone of the templates. The following list describes the available content types:

Images: Plays images. You can include multiple Images zones.

Ticker: Plays an RSS feed or pre-defined text strings. You can include multiple Ticker zones.

Clock: Displays the time or date. You can include multiple Clock zones.

Video or Images: Plays videos and images. You can include only one Video or Images zone.
Background Image: Places an image in the background of your presentation. All other zones

appear on top of the background image. When using a background image, you cannot
include a Video or Images zone. You can include only one Background Image zone.

1 Create a new project file:

a
b

C

Double-click the BrightAuthor icon on your desktop.
Click Create a new project.

In the Save As field, enter a name for the
presentation.

In the Where field, enter the folder where you want
to store the presentation. To navigate to the folder
you want to select, click Browse.

Select your BrightSign Model, Connector type,
and Screen resolution.

Click Create.

D ]

Create a new BrightSign project

Save As:  Project 2

Where: CAUser\Documents\work_projects | B er5e|

BrightSign Model: |HD1010 M

Connector type: lhDMI x. |

Screen resolution: |1920x1080x60| = |

Create H Cancel |

® o 0 0 00
=
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Click the multi-zone template you want to use, and then click Choose.
Add your Media Library:

a
b

C

On the left side of the screen, click Browse.
Navigate to the folder where your content is stored.
Click OK.

NOTE: If you have a lot of large files in your content folder, it may take a while for the thumbnail
images to appear.

Add content to each zone in your presentation:

a

Click the zone you want to populate.

NOTE each zone has its own playlist(s).

b

Drag items from the thumbunail list on the left side of the screen to the playlist bar at the top
of the main screen area.

* To select a series of adjacent files, press Shift+Click as you select the files.
* To select a group of non-adjacent files, press Ctrl+Click as you select the files.

* Toarrange thefiles in the order in which you want them to play, drag the thumbnails in the
playlist bar.

* To add an RSS feed, select the Ticker zone, click the RSS tab drag the New RSS Feed icon
onto the playlist, when prompted, enter the URL, and then click OK. Repeat this step to add
additional RSS feeds.

* To add a text feed, create a text file that contains the text. Insert a line break between each
text item in the text file. Save the text file and place it in your Media Library folder. Select
the Ticker zone, click the Text tab, and then drag the text file onto the playlist. Repeat this
step to add additional text files.

* To remove an item from a playlist, highlight it in the playlist bar and press Delete on your
PC keyboard.

Repeat steps a and b for the remaining zones.

‘1
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(Optional) Set playback options:

* To edit settings for a single item, right-click the thumbnail in the playlist bar and select Edit,
and then choose the settings you want to apply to the selected item.

* To edit settings for multiple items, press Ctrl+Click to select the items in the playlist bar. On
the menu bar, click Edit > Selected Items, and then choose the settings you want to apply to
all of the selected items.

(Optional) Rename the playlists:

a For each playlist, click Edit in the upper-right corner of the playlist bar.
b Enter a new name for the selected playlist.

¢ Click OK.

(Optional) Set zone properties. See Setting zone properties for details.



8 Onthemenu bar, click File > Save to store your presentation as indicated when you created

the project.

NOTE: To save the presentation with a different name or in a different folder, select Save As
instead of Save.

Publish the presentation on your SD card:

a Insertan SD card into your card reader.

b Click Publish in the upper-right corner.

¢ Select the drive where your SD card is located.

d When the Publish complete message appears, click OK.

Adding commands to your playlists

i A W N

To add extended functions to your presentations, you can add commands to your playlists.
Open a project file:
a Double-click the BrightAuthor icon on your desktop.
b Do one of the following:
* Click afile in the Recent Files list.
* Click Open an existing project, select the project you want to open, and then click Open.
In the upper-left corner, click a Video zone or a Video or Images zone.
In the playlist bar, click the item to which you want to apply the command.
In the Media Library pane, click the commands tab.

Drag the command you want to add into the playlist bar. The command list may include any
of the following commands:

NOTE: The commands vary based on your BrightSign model and the type of content you selected.

* Set GPIO State: Enables you turn each GPIO line on or off.
* GPIO On: Turns on the specified GPIO outputs. Other GPIO output are not affected.

‘13



* GPIO Off: Turns off the specified GPIO output.
» Wait for GPIO Input: Instructs the playlist to pause until any GPIO buttons is pressed.

GD Project 1 - Erighthuthar =R
File ~ Edit ~ Help ~ Layout Playlist Schedule &5 Publish
|»] Playlists for Zone 4 : Images 2 ©) dd New playi m
2 A [¥) Playlist 1 BT X
1 [ ] Images
5 E Zone Properties
2 B==
Media Library = E‘ bright=ign3.png interactl png
commands \\-I- Add New Dlayiier
G710.0n GPIC O
Sat GPIO State Wait for G210 Input




Using multiple playlists
Each zone can contain multiple playlists and you can schedule when you want to play each

playlist. You can use multiple playlists even when you're creating a full-screen presentation with
a single zone.

NOTE: You can't use multiple playlists in a Clock zone. A clock zone can contain only one playlist.

1 Open a project file:
a Double-click the BrightAuthor icon on your desktop.
b Do one of the following:
* Click a file in the Recent Files list.
* Click Open an existing project, select the project you want to open, and then click Open.
2 Add playlists:
a Inthe upper-left corner, click the zone to which you want to add another playlist.
b Click Add New Playlist below the playlist bar.
¢ Add content to the playlist as described earlier in this guide.
d (Optional) Repeat steps a through c to add other playlists.

3 Schedule your playlists:
a Click the Schedule tab.
b Click day, week, or the calendar icon (below the Schedule tab) to go to the date you want to
schedule.
NOTE: By default, the first playlist in a zone is scheduled to play all day, every day. To create a
schedule for individual playlists, you need to modify the schedule for the first playlist. If you have

multiple zones, you may not be able to see all days in week view. If this occurs, use day view to see
all of the days.

.15



Edit

Schedule for Zone

] VideoOrlmages
Playlists
MainLoop

SpartsHighlights.
MovieNight

Help +

L Video or Images i

Video or Images : playlists

Monday, June 29 2009

Playlist Schedule =% Publish

Video or Images [Z] Images Ticker images2 [5] time [6] date
non-stop evant non-stop avent
ron s Time: Date
§ am | MainLoop Morning2 All Day News & Events | Morning -
03:00 AM - 1130 AM 08:00 AM - 01:00 PM 08:00 AM - 0430 PM 08:00 AM - 01:00 PM
9 am
10 am
11 am
noon
1pm MainLoop Afternoon? Afternoon
01:00 PM - 04:30 PM 01:00 PM - 04:30 PM 01:00 PM - D4:30 PM
2 pm
3 pm
4 pm
9 Showing Next Week | MovienNight2
5 pm 04:30 PM - 06:30 PM 04:30 PM - D6:30 PM 04:30 PM - 0630 PM 04:30 PM - DE30 PM
6 pm
7 pm
8 pm

¢ Double-click the column associated with the zone you want to schedule.

d Click the Playlist drop-down list and select the playlist you want to schedule.

16
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Set any of the following schedule options:

* Active all day, every day: Check this box if you want the
selected playlist to play in this zone all the time. Uncheck this
box to schedule this playlist to play during a specific
timeframe.

* Event time: Sets the time when the selected playlist plays.

* Recurring Event: Check this box if you want the selected
playlist to repeat at a regular interval. To play the playlist only
today, uncheck this box.

* Recurrence pattern: Sets the repeat pattern for the selected
playlist. Select Daily or Weekly and then select the options
associated with your choice.

* Range of recurrence: Sets a start and end date for the
recurrence of the selected playlist.

Click OK.

[ CL Scheduled Event ===

Active all day, every day
Event time
Start: 8:00 AM -

End: 4:30PM ~

¥| Recurring Event
Recurrence pattern

@ Daily
Weekly

Every day
@) Every weekday

Every weekend

Range of recurrence

Start: 6/29/2009 |3

6/20/2010 [T
QK Cancel |

End: @ Mo end date
End by

Repeat steps b through e to schedule other playlists in this zone and in other zones.

NOTE: Each playlist must occupy a unique timeslot. Playlist schedules cannot overlap. If a
message appears indicating that there is a schedule conflict, look for a recurrence that begins on
another date.

® o 0o 0 00
=
~



Chapter 3
Customizing Presentations

Setting zone properties

Whether you're creating a full-screen presentation with a single zone or a multi-zone
presentation, you can customize the settings for each zone in your presentation as
described in this section. For information about changing the default zone settings,
see Setting default properties.

1 Open a project file:
a Double-click the BrightAuthor icon on your desktop.
b Do one of the following:
* Click a file in the Recent Files list.
* Click Open an existing project, select the project you want to open, and then click Open.
In the upper-left corner, click the zone for which you want to change the properties.
Click Zone Properties.
Set any of the following:
NOTE: The settings vary based on your BrightSign model and the type of zone you selected.



View Mode D toit zone |
* Scale to Fit: Scales the video to fill the screen
without maintaining the aspect ratio. Images may

View Mode: [ScaletoF\II '|

appear StretChed. Image Mode: [Scaleto Fit v|
LiveVideo
* Letterboxed and Centered: Centers theimage and put [svideo 7]
adds black borders. The aspect ratio is maintained. VideoStandarck (NTSGCM 7]
* Fill Screen and Centered: Centers the image and i
fills the screen. The aspect ratio is maintained. I
Image Mode i
* CenterImage: Centers the image without scaling ok ([ Concel ]

(may result in cropping if the image is larger than
the current videomode resolution).

* Scale to Fit: Scales the image to fit the display. The whole image is displayed as large as
possible with correct aspect ratio.

* Scale to Fill and Crop: Scales the image to fill the display while maintaining aspect ratio.
* Scale to Fill: Scales the image to fill the screen without maintaining aspect ratio.

Number of Lines
Sets the number of lines of text in a Ticker zone.

Time to Display Each Line
Sets how long each line of text displays in a Ticker zone.

Rotation
Sets the angle of the text in a Ticker zone.

Alignment
Sets whether the text is left aligned, right aligned, or centered in a Ticker zone.

Text Appearance
Sets whether the text is animated or static in a Ticker zone.



Foreground Text Color
Sets the text color in Ticker or Clock
zones.

Background Text Color
Sets the color of the background behind
the text in Ticker or Clock zones.

Transparency
Sets the transparency of the text in
Ticker or Clock zones.

Font

Sets the font of the text in Ticker or
Clock zones. You can use any TrueType
font.

Background Bitmap

G Edit Zone

Number of Lines:

Time to Display Each Line:

Rotation:

Alignment:

Text Appearance:

Foreground Text Color:

Background Text Color:

Transparency:

Font:

w | Advanced

¥ x g |

3

5

0 degrees - |
Leftaligned ~ |
9 Animated Static Text
(o)
Example R55 Text
Shows Colors
(o)

0% (100% is fully transparent)

System [ Browse |[ Reset to System Font |

CK | Cancel |

Adds the specified file as a background image. You can add a background bitmap to Ticker or

Clock zones. You can also indicate whether you want to stretch the image to fill the zone region.

Safe Text Region

Defines the location and size of the text region within the zone.

Setting sign properties
Sign properties apply to your entire presentation. The default settings are based on your current
default property settings (see Setting default properties).
1 Open a project file:
a Double-click the BrightAuthor icon on your desktop.
b Do one of the following:
* Click a file in the Recent Files list.
* Click Open an existing project, select the project you want to open, and then click Open.



On the menu bar, click File > Sign Properties.

Click the Main tab and set any of the following:

Connector type: Indicates the type of display that is
connected to the BrightSign on which you want to run the
presentation: VGA, HDMI, or Component.

Screen resolution: Sets the display resolution. Choose a
resolution that is compatible with the display that is
connected to your BrightSign.

RSS Update Frequency: Sets how often BrightSign checks
for RSS feed updates.

Background screen color: Sets the backdrop color for your
sign. Click Choose, select a color, and then click OK.

Language: Sets the date and time format in the Clock zone.

Firmware Updates: Indicates whether you want to enable

G Sign Properties

Main | Networking | /'O

Connector type: | HDMI '|
Screen resolution: .1920x1080x60p w7 |
RSS Update Frequency: |Every 5 minutes v|

Background screen color: . Choose |

Language: .English '|

Firmware Updates
Enable firmware update

Firmware update file

OK Cancel |

firmware updates and sets the location of the update file. When the Firmware Updates option
isenabled, BrightAuthor includes the specified firmware update on the SD card in a file named
UPDATE.ROK, when you publish a presentation. See the BrightSign User Guide for additional

information on updating the firmware on BrightSign.

Click the Networking tab and set any of the following:

* Enable networking: Indicates whether you want to enable networking to update content
using simple networking, and sets the location of the content files on the network.

* Check Server for New Files: Sets how often BrightSign checks the network for updates to

your content files.
Publish Network Setup Files Now: Creates a setup card.

Click the 1/0 tab and click Input or Output next to each GPIO port to indicate whether the
port is sending or receiving information.

Click OK.

e21



Customizing template layouts

If the predefined template layouts do not meet your needs, you can create your own templates.

1 Create a new project file:

a

f

Click the template that is most similar to the layout you want to use, and then click Choose.

Double-click the BrightAuthor icon on your D New propect
desktop.

Create a new BrightSign project

Click Create a new project.

i 5 As:  Project 2
In the Save As field, enter a name for the cns lade

Where:  C\User\Documentsiwaork_projects | B rowse‘

presentation.

In the Where field, enter the folder where you want BrightSign Model: [HD1010 =
to store the presentation. To navigate to the folder Connector type: (AR -
you want to select, click Browse. Screen resolution: [1920<1080x60 -

Select your BrightSign Model, Connector type,
and Screen resolution.

Create H Cancel |

Click Create.

Click the Layout tab and do any of the following:

Resize a zone by clicking the zone and then dragging the selection handles, or enter the Size
and Position information on the left side of the screen.

Make two or more zones the same size by pressing Ctrl+Click to select the zones you want to
resize. On the menu bar, click Format > Make Same Size and then select a resize option.

Align two or more zones by pressing Ctrl+Click to select the zones you want to align. On the
menu bar, click Format > Align and then select an alignment option.

Center a zone on the screen by clicking the zone you want to center. On the menu bar, click
Format > Center in Form and then select Horizontally or Vertically.

Remove an unwanted zone by clicking the zone and then pressing Delete on your keyboard.

Add azone by clicking Add Zone and then dragging the rectangle to the appropriate size and
location.

e0o 0000
N
N



* Rename a zone by entering a new label in the Name field on the left side of the screen.

TIP: You can place a Ticker zone or Clock zone on top of a video zone. You can then use the
transparency settings in the Ticker or Clock zone to control how much of the underlying video is
visible.

Click Save Template (in the upper-right corner), enter a name for the template, and then
click OK.

o PRI

File ~ Format ~ Help ~ Playlist Schedule EB Save Template

Zone

2:Images & |

5] time

2 (2] Images L

[ Images

Marme: 1] Video orImages

Images
Sizes
W: 230 H: | 255

2 (& images2
Pasition:

X 708 ¥: | 56
(6] date

(4} Add Zone =
[3] Ticker




Setting default properties

When you create a new project or add an item to a project, the settings used are based on
the default properties. If you often use the same set of properties, you can streamline the
development process by changing the default property settings to match the settings you
use most often.

NOTE: Changing the default properties does not change an existing project or its contents. To
modify an existing project or items you already added to a project, you need to change the sign
properties, zone properties, or individual item settings.

1 Open a project file:
a Double-click the BrightAuthor icon on your desktop.
b Do one of the following:
* Click a file in the Recent Files list.
* Click Open an existing project, select the project you want to open, and then click Open.
On the menu bar, click Edit > Preferences.

Click the Sign tab and select the default sign settings: o IS ]
Sign | Networkin Video | Images | Ticker | Clock
RSS Update Frequency o 2
Sets how often RSS feeds are updated. RSS Update Frequency: [Every 24 howrs v
Background Screen Color Background screen color: . @l
Sets the default background color. Click Choose, select a color,
. GPIO Configuration
and then click OK. GPIO0: @ Input © Output
. . GPIO 1: npu utpu
GPIO Configuration &PI0 2 : j; : EIEI
Sets whether each of the GPIO ports is an input port or an @103 @nput B Cuiput
OUtpUt pOft. GPIO 4 @ Input Qutput
GPIO 5: @ Input Qutput
GPIO 6: @ Input © Qutput
GPIO7: @ Input © Output
oK Cancel |

e0o 0000
N
N



4 C(lick the Networking tab and set the default
networking settings:

Metworking

Enable networking

Enable networking

|nd|CateS Whether you wa nt to enable netWOFkIng URL for web folder: (e.g., http://www.brightsign.com/files/)
and the |Ocati0n Of the netWOI‘k ﬁles. http:/fwww. brightsign, c:3r‘"la’brightsign_d::\‘\'"loac:s;l
Check Server for New Files: | Every 3 seconds -2 |
Check Server for New Files
Sets how often network files are updated. [ ok [ conel |
5 Click the Video tab and select the default video
settings:

NOTE: The settings vary based on your BrightSign model.

View Mode
» Scale to Fill: Scales the video to fill the screen without
maintaining the aspect ratio. Images may appear

i GI Edit Preferences L
|Sign Networking | Video | Images | Ticker Clockl

View Mode: [Letterboxed and Centered v|

stretched. ot
* Letterboxed and Centered: Centers the image and LiveVideo
adds black borders. The aspect ratio is maintained. inpu:[S-ideo |
Video Standard: | NTSC-M |

* Fill Screen and Centered: Centers the image and fills

Brightness: 128

the screen. The aspect ratio is maintained. Contrast: 64
Saturation: &4

Volume wlo
Sets the volume level by specifying a value between 0 and Volume: | 100

100. 100 is full volume.

Time on Screen: 0

LiveVideo
Sets the attributes for live video feeds.



6 Click the Images tab and select the default image settings:

Image Mode
* Center Image: Centers the image without scaling (may  CHIEETD

result in cropping if the image is larger than the current [ Sion | Networting [ Video] Tmages |Tickes | Glocc
videomode resolution).

Image Mode: [Scale to Fit

* Scale to Fit: Scales the image to fit the display. The whole
image is displayed as large as possible with correct aspect
ratio.

Slide Transition: [Fade to background color

Shide Delay Interval: 3

ok J[_conee |

* Scale to Fill and Crop: Scales the image to fill the display
while maintaining aspect ratio.

* Scale to Fill: Scales the image to fill the screen without
maintaining aspect ratio.

Slide Transition
Sets the effect between images. BB ot prererence) (S

. | Sign | Networking | Video | Images | Ticker | Clock
Slide Delay Interval
Sets the how long each image displays. Numberoftines: [B |

7 Click the Ticker tab and select the Time to Display Each Line: |5
default ticker settings: Rotation: [Odegress v
Number of LineS Alignment: | Left aligned "
Sets the number of lines of text in a Text Appearance: @ Animated © Static Text
Ticker Zone. Foreground Text Color: Example RSS Text @l
Shows Colors
Time to Display Each Line Background Text Color (croose |
SEtS the hOW Iong each |ine Of teXt Transparency: : 0% (100% is fully transparent)
displays in a Ticker zone.
Font:  System [ Browse |[ Reset to System Font |

ROtatiOI‘l v | Advanced
Sets the angle of the text in a Ticker ok ][ Coneel |

zone.



Alignment
Sets whether the text is left aligned, right aligned, or centered in a Ticker zone.

Text Appearance
Sets whether the text is animated or static in a Ticker zone.

Foreground Text Color
Sets the text color in Ticker zones.

Background Text Color
Sets the color of the background behind the text in Ticker zones.

Transparency
Sets the transparency of the text in Ticker zones.

Font
Sets the font of the text in Ticker zones. You can use any TrueType font. Click Browse to select a
font. Click System Font to make the current font the default system font.

Background Bitmap
Adds the specified file as a background image. You can add a background bitmap to Ticker zones.
You can also indicate whether you want to stretch the image to fill the zone region.

Safe Text Region o CIETTD
Defines the location and size of the text
region within the zone.
S e oy
Click the Clock tab and select the
default clock settings: Foreground Text Color: EEMMIELTRIN ==
Language Background Text Color: hove colos @l
Sets the date and time format. Select a Transgarency 0% (100% i fully ransparent)
language to use a predefined format. Font: (Browse] ([RescttoSystem Font )
To customize a format, click Customize Y) Advanced
Strings, enter the settings you want to —— p—

use, and then click OK.




Foreground Text Color
Sets the text color in Clock zones.

Background Text Color
Sets the color of the background behind the text in Clock zones.

Transparency
Sets the transparency of the text in Clock zones.

Font
Sets the font of the text in Clock zones. You can use any TrueType font.

Background Bitmap

Adds the specified file as a background image. You can add a background bitmap to Clock zones.

You can also indicate whether you want to stretch the image to fill the zone region.

Safe Text Region
Defines the location and size of the text region within the zone.
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Chapter 4
Updating Presentations Over a Network

BrightAuthor supports simple networking features that enable you to update presentations over
a network. To use the networking features, you must have a network-enabled BrightSign and the
content must reside in a local network or web folder. You can then configure the network-
enabled BrightSign to look for updates in the network or web folder and to download content,
schedules, firmware, and playlist changes such as adding an image transition—all from a remote
location.

Setting network sign properties

The Networking settings in Sign Properties enable the networking features for a specific
BrightSign unit and a specific presentation. To learn how to enable networking for all your
presentations, see Setting default network preferences.

1 Open a project file:
a Double-click the BrightAuthor icon on your desktop.
b Do one of the following:
* Click a file in the Recent Files list.
* Click Open an existing project, select the project you want to open, and then click Open.
On the menu bar, click File > Sign Properties.
Click the Networking tab.



4 Set any of the following: B0 Sign Properties |

* Enable networking: Indicates whether BrightSign Networking |10
checks for network updates. Networking

Enable networking

° U RL for web fOIder: Sets the Iocal network fOIder or URL for web folder: (2.g., httpy//www.brightsign.com/files/)
the Internet address of the Web folder. http:/fwww. brightsign. c::nr"l_a'brightsign_dow"loac:s.ai

* Check Server for New Files: Sets how often Check Server for New Files: ~ [Every S seconds |
BrightSign checks for new content:

Publish Network Setup Files Now |

* Every 5 seconds

* Every minute [ ok [ cancel

* Every 5 minutes

* Every hour
10PM - 2AM
5 Click Publish Network Setup Files Now and select an SD card for the setup files.

6 Insert the SD card into your BrightSign.
7 Turn on your BrightSign.

When you turn on a BrightSign HD210 or HD1010 with the Network Setup Files, it connects to
the designated web folder and checks for updates.

NOTE: /f you create a new presentation for a BrightSign that is already set up for
networking, you must enable the Networking settings in Sign Properties for that
presentation before you deliver the new presentation to the network-enabled
BrightSign.

Setting default network preferences

The Networking settings in Preferences apply to all of your new BrightAuthor presentations.
These settings do not affect any of your previously saved presentations. To learn how to enable
networking for a specific presentation, see Setting network sign properties.




1 Open a project file:
a Double-click the BrightAuthor icon on your desktop.
b Do one of the following:
* Click a file in the Recent Files list.

* Click Open an existing project, select the project you want to open, and then click Open.

On the menu bar, click Edit > Preferences.
Click the Networking tab.
Set any of the following:

* Enable networking: Indicates whether

BrightSign checks for network updates. Networcing
| Enable netwarking
e URL for web folder: Sets the local network folder URL fo et folders (. htpi /o brghtsign om/Fles)
or the Internet address of the web folder. hitpi//wwa.brightsign.com/brightsign_downloads)
* Check Server for New Files: Sets how often Check Sever for New e [Every Sseconds |

BrightSign checks for new content: ok [ conel |
* Every 5 seconds

* Every minute

* Every 5 minutes
* Every hour
10PM - 2AM

Publishing updates over the network

Whether you're adjusting the layout or updating firmware, updating your BrightSign over the
network is similar to updating content using an SD card. The only difference is where you publish
your BrightAuthor project. If you're updating a stand-alone unit, you publish directly to an SD
card. If you're updating over the network, you publish directly to the web folder (if this folder on
your local network); if the folder is not on your local network, you publish the files to your
computer and then upload the files to the web folder.
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Confirm that the time setting on the remote BrightSign is accurate.
Open a project file:
a Double-click the BrightAuthor icon on your desktop.
b Do one of the following:
* Click a file in the Recent Files list.

* Click Open an existing project, select the project you want to open, and then click Open.

Modify the project files as described earlier in this guide.
Click the Playlist tab.

Click Publish in the upper-right corner.

Browse to the web folder, and then click OK.

NOTE: /f the web folder is on a remote server, publish your content to a local folder and then
upload the content to the web folder.
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Chapter 5
Frequently Asked Questions

Can | use BrightAuthor with the HD600 or HD2000?

No, BrightAuthor only supports the HD110, HD210, HD410, HD810, and HD1010, and we do not
plan to add support for the HD600 or HD2000.

Can | open the autoplay.xml file using BrightAuthor?

No. The autoplay.xml file that is generated when you publish a project is a playlist file. This file
includes only the information required for playback on a BrightSign. This file is not the same as a
project file.

How do | use a different font?

To use a different font, browse to a folder on your computer that has a true type font. This font
will be copied to the SD card when you publish the project. You can use your own custom font
or download free TrueType fonts from the web.

Can | export a template?

Yes. While there isn't a template export option, you can save the project you're using with the
new template. You can then open the project file on another computer, click the Layout tab, and
select Save Template.

Can | use the schedule feature on the HD110 or HD410?

No. Only network-enabled units that set the time over the network, or the HD810, with a real-
time clock, can use the schedule feature.
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Can | create interactive playlists using BrightAuthor?
Not currently, but we plan to include this feature in a future update.

Can | upload my BrightAuthor project to BrightSign Network Manager?
Not currently, but we plan to include this feature in a future update.

Why does BrightAuthor take a long time to process my folder?

If the folder you selected has a large number of images and videos, the files list on the Playlist tab
may take a couple minutes to update. Please be patient.

Why can’t BrightAuthor locate my files when | try to publish my project,?
If you copy a project file from one computer to another computer, or if you move or rename files
used in a BrightAuthor project, BrightAuthor cannot locate your files and you get an error when
you try to publish. To resolve the error, you must remove the files from each playlist in your
project, and then add them again.

Why are some of my videos missing thumbnails in the Files tab?

The thumbnails are generated by codecs installed on your computer. If you don't see thumbnails
for your transport streams, for example, you can try downloading a codec such as K-Lite.

Why isn’t my presentation playing after a network update?
If you did a network update and your files are not playing, there are several things you can to
identify the cause of the problem. The first time BrightSign connects to the network it uses the
setup files you copied to the SD card to locate the web folder on your web server. Next BrightSign
checks for an updated sync file, and it downloads the updated autoplay.xml file and any files that
you added to the project. BrightSign then waits until it reaches the effective date/time set in the
sync before it plays the content.

1 BrightSign connectivity and time: Verify that BrightSign has the correct time and that it
can connect to the network. You can do this by creating a simple project that displays the
time and an RSS feed. If the network connection and Internet access are working, you see
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the RSS feed, and if you can reach the time server, you see the time. If the time zone isn't
correct, there may be several hours difference between the time on your BrightSign and the
time on your computer.

BrightAuthor settings: Open the sign, go to File > Sign Properties > Networking, and
confirm that networking is enabled. Make sure that the URL for the web folder is correct and
that it includes the correct port number for the web server, if applicable. If you haven't
already done so, publish the setup files to an SD card and insert the SD card in BrightSign.

Errors downloading files: If BrightSign encounters errors when downloading files, the
errors prevent it from restarting and playing the new content. You may encounter errors if
you moved or renamed files in the web folder after you published the presentation. To view
an error log, connect the BrightSign to your computer using a serial cable. You can also
enable BrightSign to create a log. If you're using the setup files and the initial download is
failing, open the AUTORUN.BRS file on the setup card and set loggingOn = true to
generate a LOG.TXT file. BrightSign records any errors it encounters in the log file as it
attempts to connect to the network.

File Edit Format View Help

REM

REM autorun-setup - setup file for simple network
REM February 17, 2009

REM Copyright (c) 2006-2009 Roku, Inc.

REM

Sub Main()

debugOn = true
loggingOn = true

RunSetup(debugOn, loggingOn)

4 Web server accessibility: Confirm that you can access the web folder URL from your web

browser. If your computer is also the web server, test the link from another computer.
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What do | do if BrightAuthor crashes while I'm using it?
For any errors or crashes you encounter with BrightAuthor, post a description of the problem in
the forums and be sure to include the following information:
* Steps to duplicate the problem (or indicate that you can't duplicate it)
* Any error dialogs you saw, and any text from the error dialog

* The contents of your event log right after the crash. You can find the log in this folder:
C:\Users\Owner\AppData\Local\Roku, Inc\BrightAuthor\0.0.0.1

* A copy of the project where you experience this problem
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